You're very welcome to download everything we've ever made. But be warned that we don't actively sell and develop Mailplane 3 and lower anymore.

Mailplane 4.0

Sierra or higher (10.12+)

Mailplane 3.0

Yosemite or higher (10.10+)
Mavericks (10.9)
Mountain Lion (10.8)
Lion (10.7)


Mailplane 2.5

Lion or higher (10.7+)
Snow Leopard (10.6)
Leopard (10.5)
Tiger (10.4)

Mac AppStoreMailplane 2.5 updates are still available through the Mac AppStore. Open AppStore and switch to the Purchases section.